Home

Import from/ Export to Remote

Separate non-networked computers running Filpac can "synchronize" with each other by using the Import from Remote and Export to Remote programs found in Tools->Import/Export. The Export program makes a file, with the extension TRN and by default in the FR/TRANSFER folder, consisting of all records added or changed since the specified dates. The Import program will go through the records in this file and determine if it can find a matching record. If not, it will add the record from the import file. If it finds a matching record, it will compare the date and time stamps and, if necessary, update the existing record.

Note: The limitation of this program is that it cannot synchronize file numbers. If you wish to maintain two computers with "mirror-image" datasets, you should periodically overwrite one computer's Filpac dataset with the other's. This is accomplished by moving the data files (all those in the FR folder with the extension KSH) to the FR folder of the other computer, and then running Data File Reorganization on that computer.


When using the Import/Export utility, the first thing to remember is that both computers must be running the same Filpac version. Go to Help->About and check the version number; go to the filpac.com website to download a new version of the software, if one computer is using an older version.

Exporting data to another computer that uses Filpac

Go to Tools->Import/Export->Export To Remote.

Date and Time of Last Update: The program stores the date and time of the last export. You can change the date and time if you wish. If you're changing the time, make sure you use military time, which means adding 12 to any hour after noon. (5:15 pm is written as 17:15; midnight is 24:00 but 12:15 am is 00:15 and not 24:15.) The system will export all records added or changed after this date and time.

Export File Name: On most computers it will default to \fr\transfer\export01.trn. You can change this, if you wish. To use the same file that you used before, click the Search button and browse to it, starting from the \FR\TRANSFER folder.

Committee Export: If your Filpac system is set up for multiple committees, you have the choice of exporting data from the current committee or for all committees.

Click Start and the program will take a few minutes to go through your data files, gathering all the records added and updated since the date and time you specified, and placing them in the file that you named. When finished, you can email this file to the recipient or copy it to a diskette.

Importing data from another computer that uses Filpac

Warning: Make sure you back up your Filpac data files (those in the FR folder with the extension *.KSH) before using this program. It makes permanent changes that cannot be undone.
Go to Tools->Import/Export->Import From Remote.

Import File Name: On most computers it will default to \fr\transfer\export01.trn. You can change this, if you wish. If you're not sure of the file name or where it's stored, click the Search button and browse to it, starting from the \FR\TRANSFER folder.

When you click Start, the system will display a grid of all your Filpac data files, along with a count of those records ...

Checked
Skipped(your system's version of the record is newer)
Added (couldn't find a matching record, so it added one)
Changed (found a matching record and a more recent date/time stamp)
If the import file was generated from a Filpac system with a different version, the system will warn you and then exit this program.
Here's a hint: When you use the Search button, the familiar Windows file-select dialog box will appear. On the right you'll see the buttons that enable you to go Up One Level, Create New Folder or View Menu. Click on the View Menu button. Your choices will be Thumbnails, Tiles, Icons, List and Details. Always choose Details so that you can see the date and time the files were last updated. This will help you make sure you're choosing the right file.