Home

Merging Filpac output with Microsoft Word

Although the Filpac program includes a simple letter-writing module, it was never intended to compete with the full-featured word processing products already on the market.
Filpac is designed to enhance your word processor by providing lists it can read. Merging the two products is simple, once you've learned the steps outlined below.
Although we're using Microsoft Word in the following example, the instructions would be substantially the same for Word Perfect. You must identify your main document (i.e. your letter), your data source (i.e. your list of names) and your data fields (name, address and so on).

1. The first part of any mail merge is the search. This is where you build your list. Generate your search in Filpac . For Type of Output choose Mail Merge. For the File Format choose Delimited. On most systems, this will generate a file named c:\fr\temp\let0.csv

Note: The Filpac mail merge file always starts with LET followed by your workstation's user number (zero for single-user systems), followed by an extension denoting the type of merge file:

.CSV ASCII delimited or CSV (Comma-Separated Values)
.TXT ASCII fixed-length
.DBF FoxPro 2.6

2. Open MS Word to display the document that you wish to merge with Filpac. If you don't already have one established, you can create it but first click Tools->Mail Merge. Under Main Document->Create, choose Form Letters->Active Window.

3. Name and save your merge document. Click Data Source->Get Data->Open Data Source. For the File Name, type the name of your Filpac mail merge file (c:\fr\temp\let0.csv

if yours is a single-user system and you chose Delimited during your search).

4. Make sure that Select Method is checked. Click Open. You will be asked to Confirm Data Source. Make sure Text Files (*.txt) is highlighted. Click Ok. If you need to create a document, you'll be asked to Edit Main Document.

5. To generate labels, create your merge file in Filpac as described previously. Then go to MS Word and click Tools->Mail Merge. Under Main Document, click Create->Mailing Labels->New Main Document. Under Data Source, click Get Data->Open Data Source and then type in the name of your merge file. Go to Setup Main Doc. Choose the type of label desired and click Ok. Then you can Create Label by inserting the appropriate merge fields.